summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2010-05-14 02:34:55 +0200
committerBruno Haible <bruno@clisp.org>2010-05-14 11:55:57 +0200
commitb9d488f8f3407f70aa01bed2fe992dce543207ca (patch)
treeddb5530197ab06696df82075d41ab026072c8e56 /configure.ac
parente1a35eb3ea0ebe6f64fbff403c2fc76a3044f31d (diff)
downloadlibunistring-b9d488f8f3407f70aa01bed2fe992dce543207ca.tar.gz
Publicize also the subminor version number.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 460244f..22abd5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,10 +130,16 @@ i\
0
q
'
+sed_extract_subminor='/^[0-9][0-9]*[.][0-9][0-9]*[.][0-9]/{s/^[0-9]*[.][0-9]*[.]\([0-9]*\).*/\1/p;q;}
+i\
+0
+q
+'
changequote([,])
version_major=`echo "${VERSION}" | sed -n -e "$sed_extract_major"`
version_minor=`echo "${VERSION}" | sed -n -e "$sed_extract_minor"`
-HEXVERSION=0x`$AWK 'BEGIN { printf("%02d%02d"',"$version_major","$version_minor"') }'`
+version_subminor=`echo "${VERSION}" | sed -n -e "$sed_extract_subminor"`
+HEXVERSION=0x`$AWK 'BEGIN { printf("%02X%02X%02X"',"$version_major","$version_minor","$version_subminor"') }'`
AC_SUBST([HEXVERSION])
dnl Check for tools needed for formatting the documentation.