summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-05 23:14:49 +0200
committerBruno Haible <bruno@clisp.org>2009-04-05 23:14:49 +0200
commit783fe1028e9f83b4fdde667842006ce232d5feec (patch)
tree0dcb32fc9b096bf33e3d762b61ff4feb613cbd0c /configure.ac
parenta54518dcbf59d8d04c3973324bce2055f16fbe40 (diff)
downloadlibunistring-783fe1028e9f83b4fdde667842006ce232d5feec.tar.gz
autoconf/automake based build infrastructure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 60 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..627d66b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,60 @@
+dnl Configuration for the toplevel directory of GNU libunistring
+dnl Copyright (C) 2009 Free Software Foundation, Inc.
+dnl
+dnl This program is free software: you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 3 of the License, or
+dnl (at your option) any later version.
+dnl
+dnl This program is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.63])
+AC_INIT
+AC_CONFIG_SRCDIR([lib/Makefile.am])
+AC_CONFIG_AUX_DIR([build-aux])
+. $srcdir/version.sh
+AM_INIT_AUTOMAKE([libunistring], [$VERSION_NUMBER])
+AM_CONFIG_HEADER([config.h])
+
+dnl Override automake's tar command used for creating distributions.
+am__tar='${AMTAR} chof - --owner=root --group=root "$$tardir"'
+
+dnl Checks for basic programs.
+
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+
+dnl Check for host type.
+
+AC_CANONICAL_HOST
+
+dnl Checks that augment the CPPFLAGS.
+
+gl_EARLY
+
+dnl Checks for compiler output filename suffixes.
+
+AC_OBJEXT
+AC_EXEEXT
+
+dnl Check for build configuration.
+
+LT_INIT([win32-dll])
+
+dnl Checks for types, header files, functions and declarations.
+
+gl_INIT
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([lib/Makefile])
+AC_CONFIG_FILES([tests/Makefile])
+AC_OUTPUT