summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-05-03 16:55:52 +0200
committerBruno Haible <bruno@clisp.org>2009-05-03 16:56:09 +0200
commit74deaa1963cb892a8b506f170ca94058756e4a5f (patch)
tree94604c929eba912513864381cd7a1137e6f3fcc1 /configure.ac
parent74f0ce6f023f65b2073895dcda09af5388b194b1 (diff)
downloadlibunistring-74deaa1963cb892a8b506f170ca94058756e4a5f.tar.gz
New configure option --disable-namespacing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eaca4ec..22cdcf9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,18 @@ if test $is_woe32dll = yes; then
[Define when --enable-shared is used on mingw or Cygwin.])
fi
+dnl Namespacing is the default: it builds a namespace clean library.
+dnl Allow the user to disable namespacing. This speeds up "make" considerably.
+AC_ARG_ENABLE([namespacing],
+ [ --disable-namespacing build a library that exports undesired symbols],
+ [:], [enable_namespacing=yes])
+if test "$enable_namespacing" != no; then
+ NAMESPACING=yes
+else
+ NAMESPACING=
+fi
+AC_SUBST([NAMESPACING])
+
dnl Check for prerequisites of exported.sh.
gt_GLOBAL_SYMBOL_PIPE