summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-22 04:55:25 +0200
committerBruno Haible <bruno@clisp.org>2009-04-22 04:55:25 +0200
commit5f755fddada02a264f6381974a564538950fb54a (patch)
tree9d5897918b228d3753ede01f0af977c40a58e9fc /configure.ac
parent7550f78f9b88f77309b1a233df6ef1f0e94f3035 (diff)
downloadlibunistring-5f755fddada02a264f6381974a564538950fb54a.tar.gz
Add version metainformation in Windows resource format.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6961418..eaca4ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,6 +53,18 @@ gl_WOE32_DLL
LT_INIT([win32-dll])
+dnl Prepares the libtool configuration for handling of Windows resources, and
+dnl sets the RC variable to a program that compiles Windows resource files.
+LT_LANG([Windows Resource])
+
+dnl On mingw and Cygwin, we can activate special Makefile rules which add
+dnl version information to the shared libraries and executables.
+case "$host_os" in
+ mingw* | cygwin*) is_woe32=yes ;;
+ *) is_woe32=no ;;
+esac
+AM_CONDITIONAL([WOE32], [test $is_woe32 = yes])
+
dnl Checks for types, header files, functions and declarations.
gl_INIT