summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-20 04:29:07 +0200
committerBruno Haible <bruno@clisp.org>2009-04-20 04:29:07 +0200
commit59073126ad7443e82330d38c8c59719f4826c299 (patch)
tree7c53d6d5d30d6aa72ef87cfc51cdffa0f977b0fd /configure.ac
parent6c192cf93729294f72f158653f97feabbaaaac3b (diff)
downloadlibunistring-59073126ad7443e82330d38c8c59719f4826c299.tar.gz
Support for building a shared library on Windows platforms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcea482..67783d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,15 @@ else
DLL_VARIABLE=
fi
AC_SUBST([DLL_VARIABLE])
+dnl Some parts of the tests have to be skipped when the tests are linked with
+dnl the shared library. This is because in this situation, the address of a
+dnl global variable in the shared library cannot be used as initializer of a
+dnl global or static variable.
+dnl gcc would say: "error: initializer element is not constant".
+if test $is_woe32dll = yes; then
+ AC_DEFINE([WOE32DLL], [1],
+ [Define when --enable-shared is used on mingw or Cygwin.])
+fi
dnl Check for prerequisites of exported.sh.
gt_GLOBAL_SYMBOL_PIPE