summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBruno Haible <bruno@clisp.org>2009-04-05 23:14:49 +0200
committerBruno Haible <bruno@clisp.org>2009-04-05 23:14:49 +0200
commit783fe1028e9f83b4fdde667842006ce232d5feec (patch)
tree0dcb32fc9b096bf33e3d762b61ff4feb613cbd0c /Makefile.am
parenta54518dcbf59d8d04c3973324bce2055f16fbe40 (diff)
downloadlibunistring-783fe1028e9f83b4fdde667842006ce232d5feec.tar.gz
autoconf/automake based build infrastructure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..b75c383
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+## Makefile for the toplevel directory of GNU libunistring.
+## Copyright (C) 2009 Free Software Foundation, Inc.
+##
+## This program is free software: you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3 of the License, or
+## (at your option) any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+## Process this file with automake to produce Makefile.in.
+
+AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ACLOCAL = build-aux/fixaclocal @ACLOCAL@
+ACLOCAL_AMFLAGS = -I m4 -I gnulib-m4
+
+SUBDIRS = lib tests
+
+EXTRA_DIST = BUGS
+
+
+# Allow users to use "gnulib-tool --update".
+EXTRA_DIST += gnulib-m4/gnulib-cache.m4