summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbfriesen <bfriesen>2009-08-20 22:57:38 +0000
committerbfriesen <bfriesen>2009-08-20 22:57:38 +0000
commiteaa05024a04e3fae73991a4d2ca7657d8ee60a3c (patch)
treecc7c7b2d2c8c79cc77f72495a4510c926de13058 /configure.ac
parent70af640e578944ab90b62847a16aee9b8d08e23e (diff)
downloadlibtiff-eaa05024a04e3fae73991a4d2ca7657d8ee60a3c.tar.gz
* configure.ac: Updated autotools. Autoconf 2.64, Automake 1.11,
libtool 2.2.6. Enabled support for silent build rules (--enable-silent-rules or 'make V=0') and colorized tests. * html/{index.html, v3.9.0.html}: Update for 3.9.0 release.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4ae4aaa9..e68c466f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,8 +24,8 @@ dnl OF THIS SOFTWARE.
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.59)
-AC_INIT([LibTIFF Software], 4.0.0beta3, [tiff@lists.maptools.org], tiff)
+AC_PREREQ(2.64)
+AC_INIT([LibTIFF Software],[4.0.0beta3],[tiff@lists.maptools.org],[tiff])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(m4)
AC_LANG(C)
@@ -100,8 +100,17 @@ VL_PROG_CC_WARNINGS()
AC_PROG_INSTALL
AC_PROG_LN_S
-AC_LIBTOOL_WIN32_DLL
-AC_PROG_LIBTOOL
+
+dnl Tests for Windows
+AC_EXEEXT
+AC_OBJEXT
+
+dnl initialize libtool
+LT_INIT([win32-dll])
+LT_LANG([C++])
+
+# Enable support for silent build rules
+AM_SILENT_RULES
dnl Checks for libraries.
AC_CHECK_LIB([c], [main])