summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbfriesen <bfriesen>2012-08-19 16:56:32 +0000
committerbfriesen <bfriesen>2012-08-19 16:56:32 +0000
commite3e341eece7cf396dc205a99875cb04dff1f40b1 (patch)
tree4f064da34ad446eaf112f5a19bc796745de5531b /configure.ac
parent685c78073cf82f1fca54545fd84af9a9b16a423d (diff)
downloadlibtiff-e3e341eece7cf396dc205a99875cb04dff1f40b1.tar.gz
* libtiff{tiff.h, tif_print.c, tif_dirinfo.c, tif_dirread.c}: Add
some TIFF/FX support in libtiff. Add the tag definitions to tiff.h. Add the related TIFF field definitions to tif_dirinfo.c, and also fixes an error in a comment. Adds the photometric values to tif_print.c, and fixes a bug. These changes are by Steve Underwood. * libtiff/tif_write.c: Fix bug rewriting image tiles in a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1405eb57..08757f1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,9 +154,6 @@ LT_LANG([C++])
# Enable support for silent build rules
AM_SILENT_RULES
-dnl Checks for libraries.
-AC_CHECK_LIB([c], [main])
-
dnl We don't need to add math library to all targets
case "${host_os}" in
cygwin* | mingw32* | beos* | darwin*)
@@ -813,10 +810,17 @@ dnl ---------------------------------------------------------------------------
HAVE_OPENGL=no
+
AC_PATH_XTRA
+dnl AX_CHECK_GL sets GL_CFLAGS & GL_LIBS. Also PTHREAD_LIBS,
+dnl PTHREAD_CFLAGS, & PTHREAD_CC as a side-effect
AX_CHECK_GL
+
+dnl AX_CHECK_GLU sets GLU_CFLAGS & GLU_LIBS
AX_CHECK_GLU
+
+dnl AX_CHECK_GLUT sets GLUT_CFLAGS & GLUT_LIBS
AX_CHECK_GLUT
if test "$no_x" != "yes" -a "$no_gl" != "yes" \