summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbfriesen <bfriesen>2015-06-25 02:27:58 +0000
committerbfriesen <bfriesen>2015-06-25 02:27:58 +0000
commite1d7bb3dba9e63fab57d8cb79bfd40d3ba9a06ed (patch)
tree12e541bab27713a9f6e71d0976c9614aa1ec27af /configure.ac
parentf06106c28c701f3c65ae64661e711e7ec93d9346 (diff)
downloadlibtiff-e1d7bb3dba9e63fab57d8cb79bfd40d3ba9a06ed.tar.gz
* CMakeLists.txt: Add CMake patchset by Roger Leigh as posted to
libtiff mailing list on Mon, 22 Jun 2015 21:21:01 +0100. Several corrections to ensure that the autotools build still works were added by me. I have not yet tested the build using 'cmake' or MSVC with 'nmake'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7ba14ee9..b033bca3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -414,11 +414,12 @@ AC_CHECK_TYPES([int8, int16, int32],,,
])
dnl Checks for library functions.
-AC_CHECK_FUNCS([floor isascii memmove memset mmap pow setmode sqrt\
- strchr strrchr strstr strtol strtoull])
+AC_CHECK_FUNCS([floor isascii memmove memset mmap pow setmode snprintf sqrt \
+strchr strrchr strstr strtol strtoul strtoull])
dnl Will use local replacements for unavailable functions
AC_REPLACE_FUNCS(getopt)
+AC_REPLACE_FUNCS(snprintf)
AC_REPLACE_FUNCS(strcasecmp)
AC_REPLACE_FUNCS(strtoul)
AC_REPLACE_FUNCS(strtoull)