summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbfriesen <bfriesen>2015-06-21 18:46:29 +0000
committerbfriesen <bfriesen>2015-06-21 18:46:29 +0000
commit8af53c421f17aea1e1f72dd5da6dc4fc4ffcba4b (patch)
tree77f26044556e438c4b8f4fb2c4ac1ca3750fe660 /configure.ac
parent2a4f5b125a262c3c66db426ff2cb44e4b9282705 (diff)
downloadlibtiff-8af53c421f17aea1e1f72dd5da6dc4fc4ffcba4b.tar.gz
* configure.ac: Add a HAVE_FOO Automake conditional for each
add-on library. * test/Makefile.am (JPEG_DEPENDENT_CHECK_PROG): raw_decode requires JPEG support to compile. Use Automake conditional to only include it when JPEG support is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7851956c..5448dc07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,6 +688,8 @@ if test "$HAVE_JPEG" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_JPEG, test "$HAVE_JPEG" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Check for Old JPEG.
dnl ---------------------------------------------------------------------------
@@ -760,6 +762,8 @@ if test "$HAVE_JBIG" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_JBIG, test "$HAVE_JBIG" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Check for liblzma2.
dnl ---------------------------------------------------------------------------
@@ -812,6 +816,8 @@ if test "$HAVE_LZMA" = "yes" ; then
fi
+AM_CONDITIONAL(HAVE_LZMA, test "$HAVE_LZMA" = 'yes')
+
dnl ---------------------------------------------------------------------------
dnl Should 8/12 bit jpeg mode be enabled?
dnl ---------------------------------------------------------------------------