summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorbfriesen <bfriesen>2015-09-06 19:34:06 +0000
committerbfriesen <bfriesen>2015-09-06 19:34:06 +0000
commit47e17c19b07abe7fdf7c63f1c27e3096a1d694b4 (patch)
treecae7d45a629e1580d16798a435c4582477717081 /Makefile.am
parentc191c026a49f966a13ac35ba019403ea9e011a2c (diff)
downloadlibtiff-47e17c19b07abe7fdf7c63f1c27e3096a1d694b4.tar.gz
* Makefile.am: Added a 'coverity' rule to assist with Coverity
submissions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c5fc74f4..418a3b93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,3 +70,22 @@ release:
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libtiff-4.pc
+
+# Special rules to assist with Coverity submissions.
+PACKAGE_CHANGE_DATE=`awk '/^[0-9][0-9][0-9][0-9]-[0-9][0-9]-[0-9][0-9]/ { print substr($$1,1,4) substr($$1,6,2) substr($$1,9,2); exit; }' $(top_srcdir)/ChangeLog`
+COVERITY_EMAIL=bfriesen@simple.dallas.tx.us
+COVERITY_TARBALL=libtiff.xz
+COVERITY_VERSION=devel-${PACKAGE_CHANGE_DATE}
+COVERITY_DESCRIPTION='libtiff development'
+coverity:
+ $(MAKE) clean
+ cov-build --dir cov-int $(MAKE)
+ tar caf $(COVERITY_TARBALL) cov-int
+ curl --limit-rate 50K \
+ --form token=`cat $$HOME/.coverity_key_tiff` \
+ --form email=$(COVERITY_EMAIL) \
+ --form file=@$(COVERITY_TARBALL) \
+ --form version=$(COVERITY_VERSION) \
+ --form description=$(COVERITY_DESCRIPTION) \
+ https://scan.coverity.com/builds?project=tiff
+ $(RM) $(COVERITY_TARBALL)