summaryrefslogtreecommitdiff
path: root/libtiff/CMakeLists.txt
diff options
context:
space:
mode:
authorEven Rouault <even.rouault@spatialys.com>2017-12-21 13:32:02 +0100
committerEven Rouault <even.rouault@spatialys.com>2017-12-21 13:32:02 +0100
commit62b9df5d2af68262fa6fcfb66086bf128f7d67c3 (patch)
tree92e37acfbaad84520c6b89e9479653820511d3ea /libtiff/CMakeLists.txt
parent5848777bd7e4f465681a7c4d0acf96a1dbd5b75c (diff)
downloadlibtiff-git-62b9df5d2af68262fa6fcfb66086bf128f7d67c3.tar.gz
Add ZSTD compression codec
From https://github.com/facebook/zstd "Zstandard, or zstd as short version, is a fast lossless compression algorithm, targeting real-time compression scenarios at zlib-level and better compression ratios. It's backed by a very fast entropy stage, provided by Huff0 and FSE library." We require libzstd >= 1.0.0 so as to be able to use streaming compression and decompression methods. The default compression level we have selected is 9 (range goes from 1 to 22), which experimentally offers equivalent or better compression ratio than the default deflate/ZIP level of 6, and much faster compression. For example on a 6600x4400 16bit image, tiffcp -c zip runs in 10.7 seconds, while tiffcp -c zstd runs in 5.3 seconds. Decompression time for zip is 840 ms, and for zstd 650 ms. File size is 42735936 for zip, and 42586822 for zstd. Similar findings on other images. On a 25894x16701 16bit image, Compression time Decompression time File size ZSTD 35 s 3.2 s 399 700 498 ZIP/Deflate 1m 20 s 4.9 s 419 622 336
Diffstat (limited to 'libtiff/CMakeLists.txt')
-rw-r--r--libtiff/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libtiff/CMakeLists.txt b/libtiff/CMakeLists.txt
index 087dfa9e..34107efb 100644
--- a/libtiff/CMakeLists.txt
+++ b/libtiff/CMakeLists.txt
@@ -94,7 +94,8 @@ set(tiff_SOURCES
tif_version.c
tif_warning.c
tif_write.c
- tif_zip.c)
+ tif_zip.c
+ tif_zstd.c)
set(tiffxx_HEADERS
tiffio.hxx)