summaryrefslogtreecommitdiff
path: root/libtiff/CMakeLists.txt
diff options
context:
space:
mode:
authorBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-08-14 02:26:37 +0000
committerBob Friesenhahn <bfriesen@simple.dallas.tx.us>2015-08-14 02:26:37 +0000
commit01aa45a312422b47bf4ec7c7c3952ecc9e8df0cd (patch)
tree8b2bbee4572849edbc0851a70e2e3480737981a5 /libtiff/CMakeLists.txt
parent80dc16cf74a2e52f87f9ce0bbd625275d495d7b5 (diff)
downloadlibtiff-git-01aa45a312422b47bf4ec7c7c3952ecc9e8df0cd.tar.gz
CMakeLists.txt fix for libtiffxx symbol versioning.
Diffstat (limited to 'libtiff/CMakeLists.txt')
-rw-r--r--libtiff/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/libtiff/CMakeLists.txt b/libtiff/CMakeLists.txt
index 72e49e62..58eb1280 100644
--- a/libtiff/CMakeLists.txt
+++ b/libtiff/CMakeLists.txt
@@ -149,16 +149,16 @@ install(FILES ${tiff_HEADERS} ${nodist_tiff_HEADERS}
if(cxx)
add_library(tiffxx SHARED ${tiffxx_SOURCES} ${tiffxx_HEADERS})
target_link_libraries(tiffxx tiff)
- set_target_properties(tiff PROPERTIES SOVERSION ${SO_COMPATVERSION})
+ set_target_properties(tiffxx PROPERTIES SOVERSION ${SO_COMPATVERSION})
if(NOT CYGWIN)
# This property causes shared libraries on Linux to have the full version
# encoded into their final filename. We disable this on Cygwin because
# it causes cygz-${TIFF_FULL_VERSION}.dll to be created when cygz.dll
# seems to be the default.
- set_target_properties(tiff PROPERTIES VERSION ${SO_VERSION})
+ set_target_properties(tiffxx PROPERTIES VERSION ${SO_VERSION})
endif()
if(HAVE_LD_VERSION_SCRIPT)
- set_target_properties(tiff PROPERTIES LINK_FLAGS
+ set_target_properties(tiffxx PROPERTIES LINK_FLAGS
"-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/libtiffxx.map")
endif()