summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2006-10-13 10:15:35 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2006-10-13 10:15:35 +0000
commitda07e8372e03fc019b9fc051f9ce44d9c4c5d4ae (patch)
treebc8db08d19dcd37ad8649dd4dd51dad8662d38e5 /configure.ac
parent5338cd561ef2586c20527ca352296c54828b6168 (diff)
downloadlibtiff-git-da07e8372e03fc019b9fc051f9ce44d9c4c5d4ae.tar.gz
Added test for X Athena widgets.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8562af7..eeee3b07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -478,9 +478,19 @@ dnl Check for OpenGL and GLUT.
dnl ---------------------------------------------------------------------------
HAVE_OPENGL=no
+HAVE_XAW=no
AC_PATH_XTRA
+ICE_FIND_ATHENA
+
+if test "$no_xaw" != "yes" ; then
+ HAVE_XAW=yes
+fi
+
+AM_CONDITIONAL(HAVE_XAW, test "$HAVE_XAW" = "yes")
+
+
AX_CHECK_GL
AX_CHECK_GLU
AX_CHECK_GLUT
@@ -619,6 +629,7 @@ LOC_MSG([ ISO JBIG support: ${HAVE_JBIG}])
LOC_MSG()
LOC_MSG([ C++ support: ${HAVE_CXX}])
LOC_MSG()
+LOC_MSG([ X Athena Widgets support: ${HAVE_XAW}])
LOC_MSG([ OpenGL support: ${HAVE_OPENGL}])
LOC_MSG()