summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2005-05-26 08:16:00 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2005-05-26 08:16:00 +0000
commitd72e52d31d1897c37bee34c845369445dc525fb9 (patch)
tree1638a277bf72c07a4a6243c3b2ace9d3f435f1e6 /configure.ac
parenta4d796bca404793cbbecd85d9226175910f169ba (diff)
downloadlibtiff-git-d72e52d31d1897c37bee34c845369445dc525fb9.tar.gz
Added workaround for OpenBSD/MirOS soname problem as per bug
http://bugzilla.remotesensing.org/show_bug.cgi?id=838
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e3170e1f..0c7d5a4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,11 +46,25 @@ LIBTIFF_VERSION=$LIBTIFF_MAJOR_VERSION.$LIBTIFF_MINOR_VERSION.$LIBTIFF_MICRO_VER
dnl This will be used with the 'make release' target
LIBTIFF_RELEASE_DATE=`date +"%Y%m%d"`
+# This is a special hack for OpenBSD and MirOS systems. The dynamic linker
+# in OpenBSD uses some special semantics for shared libraries. Their soname
+# contains only two numbers, major and minor.
+# See http://bugzilla.remotesensing.org/show_bug.cgi?id=838 for details.
+case "$target_os" in
+ openbsd* | mirbsd*)
+ LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION:0
+ ;;
+ *)
+ LIBTIFF_VERSION_INFO=$LIBTIFF_MAJOR_VERSION:$LIBTIFF_MINOR_VERSION:$LIBTIFF_MICRO_VERSION$LIBTIFF_ALPHA_VERSION
+ ;;
+esac
+
AC_SUBST(LIBTIFF_MAJOR_VERSION)
AC_SUBST(LIBTIFF_MINOR_VERSION)
AC_SUBST(LIBTIFF_MICRO_VERSION)
AC_SUBST(LIBTIFF_ALPHA_VERSION)
AC_SUBST(LIBTIFF_VERSION)
+AC_SUBST(LIBTIFF_VERSION_INFO)
AC_SUBST(LIBTIFF_RELEASE_DATE)
dnl Checks for programs.