summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2005-01-15 17:24:52 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2005-01-15 17:24:52 +0000
commitc0d1f11f5729b0b20d00ea9483000897e7aede48 (patch)
tree0de97d2761132f9ec5ce9d9f9080f9d6919f729d /configure.ac
parentf284d8e843a220abbc4cdc542af48ac2eb58f163 (diff)
downloadlibtiff-git-c0d1f11f5729b0b20d00ea9483000897e7aede48.tar.gz
*** empty log message ***
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5583a143..9efae52f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,21 @@ dnl ---------------------------------------------------------------------------
AC_SYS_LARGEFILE
dnl ---------------------------------------------------------------------------
+dnl Point to path where we should install documentation.
+dnl ---------------------------------------------------------------------------
+
+LIBTIFF_DOCDIR=${ac_default_prefix}/share/doc/${PACKAGE}-${LIBTIFF_VERSION}/html
+
+AC_ARG_WITH(docdir,
+ AS_HELP_STRING([--with-docdir=DIR],
+ [directory where documentation should be installed]),,)
+if test "x$with_docdir" != "x" ; then
+ LIBTIFF_DOCDIR=$with_docdir
+fi
+
+AC_SUBST(LIBTIFF_DOCDIR)
+
+dnl ---------------------------------------------------------------------------
dnl Switch on/off internal codecs.
dnl ---------------------------------------------------------------------------
@@ -479,6 +494,7 @@ LOC_MSG()
LOC_MSG([Libtiff is now configured for ${host}])
LOC_MSG()
LOC_MSG([ Installation directory: ${prefix}])
+LOC_MSG([ Documentation directory: ${LIBTIFF_DOCDIR}])
LOC_MSG([ C compiler: ${CC} ${CFLAGS}])
LOC_MSG([ C++ compiler: ${CXX} ${CXXFLAGS}])
LOC_MSG([ Enable runtime linker paths: ${HAVE_RPATH}])