summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2005-07-04 12:39:54 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2005-07-04 12:39:54 +0000
commit143ed91af38a6f95acaa554282c42c833951dccd (patch)
treeb0ae9f9ff9d58789e1e361e5379829851010c12d /configure.ac
parent6625d0be129605afee0f1938008284195e35cf3f (diff)
downloadlibtiff-git-143ed91af38a6f95acaa554282c42c833951dccd.tar.gz
Do not use empty -R option when linking with --enable-rpath.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 674da4ce..c5e33565 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,7 +293,7 @@ if test "$HAVE_ZLIB" = "yes" ; then
AC_DEFINE(ZIP_SUPPORT,1,[Support Deflate compression])
LIBS="-lz $LIBS"
- if test "$HAVE_RPATH" = "yes"; then
+ if test "$HAVE_RPATH" = "yes" -a "x$with_zlib_lib_dir" != "x" ; then
LIBDIR="-R $with_zlib_lib_dir $LIBDIR"
fi
@@ -361,7 +361,7 @@ if test "$HAVE_JPEG" = "yes" ; then
AC_DEFINE(JPEG_SUPPORT,1,[Support JPEG compression (requires IJG JPEG library)])
LIBS="-ljpeg $LIBS"
- if test "$HAVE_RPATH" = "yes"; then
+ if test "$HAVE_RPATH" = "yes" -a "x$with_jpeg_lib_dir" != "x" ; then
LIBDIR="-R $with_jpeg_lib_dir $LIBDIR"
fi