summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Kiselev <dron@ak4719.spb.edu>2004-11-12 12:52:16 +0000
committerAndrey Kiselev <dron@ak4719.spb.edu>2004-11-12 12:52:16 +0000
commit078099ab9cd511d64f7236bd58763327ff84063e (patch)
tree8c1a3f9fe5494ff222137c8b9a3fd6765f5f4ef7 /configure.ac
parentf9fb6c863e4e93c887882fb76ca4e76fd812c280 (diff)
downloadlibtiff-git-078099ab9cd511d64f7236bd58763327ff84063e.tar.gz
Add support for C++ stream API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac6cfb86..dcb799ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,6 +353,23 @@ else
fi
dnl ---------------------------------------------------------------------------
+dnl Check for C++.
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_ENABLE(c++,
+ AS_HELP_STRING([--enable-c++],
+ [enable C++ stream API building (requires C++ compiler)]),
+ [HAVE_CXX=$enableval], [HAVE_CXX=yes])
+
+if test "$HAVE_CXX" = "yes" ; then
+ AC_DEFINE(CXX_SUPPORT, 1, [Support C++ stream API (requires C++ compiler)])
+else
+ HAVE_CXX=no
+fi
+
+AM_CONDITIONAL(HAVE_CXX, test "$HAVE_CXX" = "yes")
+
+dnl ---------------------------------------------------------------------------
dnl Check for OpenGL and GLUT.
dnl ---------------------------------------------------------------------------
@@ -463,6 +480,7 @@ LOC_MSG([Libtiff is now configured for ${host}])
LOC_MSG()
LOC_MSG([ Installation directory: ${prefix}])
LOC_MSG([ C compiler: ${CC} ${CFLAGS}])
+LOC_MSG([ C++ compiler: ${CXX} ${CXXFLAGS}])
LOC_MSG([ Enable runtime linker paths: ${HAVE_RPATH}])
LOC_MSG()
LOC_MSG([ Support for internal codecs:])
@@ -479,6 +497,8 @@ LOC_MSG([ Pixar log-format algorithm: ${HAVE_PIXARLOG}])
LOC_MSG([ JPEG support: ${HAVE_JPEG}])
LOC_MSG([ Old JPEG support: ${HAVE_OJPEG}])
LOC_MSG()
+LOC_MSG([ C++ support: ${HAVE_CXX}])
+LOC_MSG()
LOC_MSG([ OpenGL support: ${HAVE_OPENGL}])
LOC_MSG()