summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoralex <alex>2000-12-13 07:28:42 +0000
committeralex <alex>2000-12-13 07:28:42 +0000
commit802764bbc006b3eea86131b798b288d367b8ebc5 (patch)
tree3ff0f9ab280fe5ee760a03cf9041d2e91f218156 /Makefile.am
parent5444286ae10582bf6d7d1f41c40873361c368b64 (diff)
downloadlibsoup-802764bbc006b3eea86131b798b288d367b8ebc5.tar.gz
Beginnings of test-suite added.
* Beginnings of test-suite added. * Made SoupContext opaque. Removed SoupContextPrivate. Added soup_context_get_uri() to get the uri string for a given context. * Added a response_headers hashtable to SoupRequest so the callback can do whatever it wants with passed headers. All entries in this hashtable are just parsed strings from req->priv->recv_buf, so no new strings are allocated. * Renamed custom_headers to request_headers * Fixed context creation logic * Made soup_servers hashtable use case insensitive hostname matching. * Removed SOUP_ERROR_URI_NOT_FOUND, SOUP_ERROR_URI_NOT_PERMITTED, and SOUP_ERROR_URI_OBJECT_MOVED from SoupCallbackResult enum. Its up to the application to figure out all the different HTTP states. This may change however. * Added querystring to SoupUri, so that contexts can be cached based only on path. * Added default port logic to SoupUri. Known protocols are https (port 443), http (80), smtp/mailto (25), and ftp (20).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 45d5428d..8a5aabeb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = src
+SUBDIRS = src tests
EXTRA_DIST = \
autogen.sh