summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2001-03-07 17:21:12 +0000
committerJP Rosevear <jpr@src.gnome.org>2001-03-07 17:21:12 +0000
commit385604c36fb2c3190288d182c4bfefc158ec803c (patch)
tree8aa20e0d386d8c49235a43bcd0a109bb6682ee8c /Makefile.am
parent1cb19005d36d848a9635122ed54758b0d4f5cae3 (diff)
downloadlibsoup-385604c36fb2c3190288d182c4bfefc158ec803c.tar.gz
use configure.in vars for subst
2001-03-07 JP Rosevear <jpr@ximian.com> * soupConf.sh.in: use configure.in vars for subst * configure.in: create variables for config script * Makefile.am: generate the soupConf.sh script in the makefile for proper substitution
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8abb0658..d13b1572 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,14 @@ EXTRA_DIST = autogen.sh soupConf.sh.in soup.pc.in soup.spec.in
bin_SCRIPTS = soup-config
+soupConf.sh: $(top_srcdir)/soupConf.sh.in Makefile
+ sed -e 's?\@SOUP_LIBDIR\@?$(SOUP_LIBDIR)?g' \
+ -e 's?\@SOUP_INCLUDEDIR\@?$(SOUP_INCLUDEDIR)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ -e 's?\@SOUP_LIBS\@?$(SOUP_LIBS)?g' \
+ < $(top_srcdir)/soupConf.sh.in > soupConf.tmp \
+ && mv soupConf.tmp soupConf.sh
+
confexecdir = $(libdir)
confexec_DATA = soupConf.sh
@@ -17,3 +25,5 @@ dist-hook: soup.spec
rpms: distcheck
rpm -ta $(top_builddir)/@PACKAGE@-@VERSION@.tar.gz
+
+CLEANFILES = soupConf.sh