summaryrefslogtreecommitdiff
path: root/rsvg_convert/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rsvg_convert/Cargo.toml')
-rw-r--r--rsvg_convert/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/rsvg_convert/Cargo.toml b/rsvg_convert/Cargo.toml
new file mode 100644
index 00000000..035b2419
--- /dev/null
+++ b/rsvg_convert/Cargo.toml
@@ -0,0 +1,50 @@
+[package]
+name = "rsvg_convert"
+version.workspace = true
+authors.workspace = true
+description.workspace = true
+license.workspace = true
+homepage.workspace = true
+repository.workspace = true
+edition.workspace = true
+rust-version.workspace = true
+
+# So that we can use an rsvg-convert name instead of the default rsvg_convert
+autobins = false
+
+[package.metadata.system-deps]
+cairo-pdf = { version = "1.16", optional = true }
+cairo-ps = { version = "1.16", optional = true }
+cairo-svg = { version = "1.16", optional = true }
+
+[dependencies]
+# Keep these in sync with respect to the cairo-rs version:
+# src/lib.rs - toplevel example in the docs
+cairo-rs = { version = "0.17", features=["v1_16", "png", "pdf", "ps", "svg"] }
+cast = "0.3.0"
+chrono = { version = "0.4.23", default-features = false, features = ["clock", "std"] }
+clap = { version = "4.0.17", features = ["cargo", "derive"] } # rsvg-convert
+clap_complete = "4.0.5" # rsvg-convert
+cssparser = "0.29.0"
+gio = "0.17"
+glib = "0.17"
+libc = "0.2"
+librsvg = { path = "../rsvg" }
+librsvg-c = { path = "../librsvg-c" }
+
+[dev-dependencies]
+assert_cmd = "2.0.2"
+predicates = "3.0.3"
+tempfile = "3"
+url = "2"
+lopdf = "0.30.0"
+png = "0.17.2"
+float-cmp = "0.9.0"
+librsvg = { path = "../rsvg", features = ["test-utils"] }
+
+[build-dependencies]
+system-deps = "6.0.0"
+
+[[bin]]
+name = "rsvg-convert"
+path = "src/main.rs"