summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKleis Auke Wolthuizen <github@kleisauke.nl>2022-03-24 18:40:37 +0100
committerMarge Bot <marge-bot@gnome.org>2022-04-07 15:20:24 +0000
commit14a7d3853e586694d814de13ad6bd39dc0bb89c4 (patch)
treec49c4a7cbfb3dcc6541a43c7113c232d65940b7f /configure.ac
parent39a6d3418c0df8ca5ea4d0df3e1b14b915c75608 (diff)
downloadlibrsvg-14a7d3853e586694d814de13ad6bd39dc0bb89c4.tar.gz
(#859): Make rst2man and gi-docgen optional
Fixes #859. Part-of: <https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/687>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4e356a9..a88b55d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,15 +117,17 @@ dnl Man page generator
AC_CHECK_PROGS(RST2MAN, [rst2man rst2man.py], [no])
AS_IF(test x$RST2MAN = xno,
- AC_MSG_ERROR([rst2man is required. Please install python3-docutils.])
+ AC_MSG_WARN([rst2man not found - not building man pages])
)
+AM_CONDITIONAL(HAVE_RST2MAN, [test "x$RST2MAN" != "xno"])
dnl Gi-docgen
AC_CHECK_TOOL(GI_DOCGEN, [gi-docgen], [no])
AS_IF(test x$GI_DOCGEN = xno,
- AC_MSG_ERROR([gi-docgen is required. Please install it.])
+ AC_MSG_WARN([gi-docgen not found - not building docs])
)
+AM_CONDITIONAL(HAVE_GI_DOCGEN, [test "x$GI_DOCGEN" != "xno"])
dnl ===========================================================================