summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2018-02-07 12:31:54 -0600
committerFederico Mena Quintero <federico@gnome.org>2018-02-20 13:00:11 -0600
commitfe3297f336b712d44e70f4a6af5f8e08f9e0c59a (patch)
treeaf802127fc7266d97ce6f8d0beb7321425de9b00 /Makefile.am
parent4bb8914a7e062cad29480c7f2f2b8fa0ed82a1d3 (diff)
downloadlibrsvg-fe3297f336b712d44e70f4a6af5f8e08f9e0c59a.tar.gz
Generate a PHF of SVG attribute names
We will map SVG attribute names to enum values using a Perfect Hash Function, instead of doing string comparisons and hash table lookups everywhere. At build time, we generate the PHF mapping. We do this with phf_codegen (in the build.rs script) instead of phf_macros, as the latter cannot be used on Rust stable yet.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e7a7ae77..5cdf82d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,7 +64,9 @@ librsvg_@RSVG_API_MAJOR_VERSION@_la_SOURCES = \
RUST_SOURCES = \
rust/Cargo.toml \
+ rust/build.rs \
rust/src/aspect_ratio.rs \
+ rust/src/attributes.rs \
rust/src/bbox.rs \
rust/src/chars.rs \
rust/src/clip_path.rs \