summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2010-06-15 21:11:39 +0200
committerChristian Persch <chpe@gnome.org>2010-06-22 15:50:14 +0200
commit3d28e419d726d972b178325c25b4f8d17aca17c1 (patch)
tree31519ce3960bda13eb805cfdced03224f8bd1f35 /Makefile.am
parent28c2a570027b7d0b46b9e05a31757c09093e558f (diff)
downloadlibrsvg-3d28e419d726d972b178325c25b4f8d17aca17c1.tar.gz
Add GIO convenience to librsvg
Adds rsvg_handle_read_stream_sync() to read the handle's data from a GInputStream, and rsvg_handle_new_from_{gfile,stream}_sync convenience functions analogous to rsvg_handle_new_from_{file,data}. Bug #621699.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ce74c724..578ffaea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,7 +62,9 @@ librsvg_@RSVG_API_MAJOR_VERSION@_la_SOURCES = \
rsvg-cairo-clip.c \
rsvg.c \
rsvg-gobject.c \
- rsvg-file-util.c
+ rsvg-file-util.c \
+ rsvg-xml.c \
+ rsvg-xml.h
librsvg_@RSVG_API_MAJOR_VERSION@_la_LDFLAGS = -version-info @RSVG_LT_VERSION_INFO@ -export-dynamic -no-undefined -export-symbols $(srcdir)/librsvg.def
librsvg_@RSVG_API_MAJOR_VERSION@_la_LIBADD = $(LIBGSF_LIBS) $(LIBCROCO_LIBS) $(LIBRSVG_LIBS) -lm