summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2023-01-30 16:47:08 -0600
committerFederico Mena Quintero <federico@gnome.org>2023-01-30 16:47:08 -0600
commit5da5708d55271a26b7f045d8fa5864acebad7042 (patch)
tree8f9be8c574784bd3e46f08ade625557490735b60 /Cargo.toml
parentf00e76e493766f47e2f44e0dc688fd0b760f8982 (diff)
downloadlibrsvg-5da5708d55271a26b7f045d8fa5864acebad7042.tar.gz
rsvg-bench.rs: Port from the failure crate to anyhow/thiserror
Part-of: <https://gitlab.gnome.org/GNOME/librsvg/-/merge_requests/789>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 811b25c6..20babd44 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,6 +51,7 @@ crate-type = [ "staticlib", "rlib" ]
[dependencies]
# Keep these in sync with respect to the cairo-rs version:
# src/lib.rs - toplevel example in the docs
+anyhow = "1.0"
byteorder = "1.4"
cairo-rs = { version = "0.16", features=["v1_16", "png", "pdf", "ps", "svg"] }
cast = "0.3.0"
@@ -80,6 +81,7 @@ regex = "1"
rgb = { version="0.8", features=["argb"] }
selectors = "0.23.0"
string_cache = "0.8.0"
+thiserror = "1.0"
tinyvec = { version = "1.2.0", features = ["alloc"] }
url = "2"
xml5ever = "0.17.0"