summaryrefslogtreecommitdiff
path: root/libproxy/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libproxy/test/CMakeLists.txt')
-rw-r--r--libproxy/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/libproxy/test/CMakeLists.txt b/libproxy/test/CMakeLists.txt
index 69543a4..8894425 100644
--- a/libproxy/test/CMakeLists.txt
+++ b/libproxy/test/CMakeLists.txt
@@ -17,3 +17,10 @@ if(WIN32)
target_link_libraries(url-encode ws2_32)
endif()
add_test(NAME url-encode COMMAND ${CMAKE_CURRENT_BINARY_DIR}/url-encode)
+
+# Get PAC
+if (NOT WIN32)
+add_executable(get-pac-test ${CMAKE_CURRENT_SOURCE_DIR}/get-pac-test.cpp ${PROJECT_SOURCE_DIR}/url.cpp)
+target_link_libraries(get-pac-test pthread)
+add_test(NAME get-pac-test COMMAND ${CMAKE_CURRENT_BINARY_DIR}/get-pac-test)
+endif()