summaryrefslogtreecommitdiff
path: root/libproxy/CMakeLists.txt
diff options
context:
space:
mode:
authornpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-26 02:00:05 +0000
committernpmccallum <npmccallum@c587cffe-e639-0410-9787-d7902ae8ed56>2010-01-26 02:00:05 +0000
commit1413dcea3932fe0e1750fb69414a5c78769393be (patch)
treedc4e3ec9208a8dea19974010704bb8aa3b3e8f38 /libproxy/CMakeLists.txt
parentdc553a67667728f12ba3187da8f918e41e876400 (diff)
downloadlibproxy-1413dcea3932fe0e1750fb69414a5c78769393be.tar.gz
fix cmake bug causing errors when deps not found
git-svn-id: http://libproxy.googlecode.com/svn/trunk@508 c587cffe-e639-0410-9787-d7902ae8ed56
Diffstat (limited to 'libproxy/CMakeLists.txt')
-rw-r--r--libproxy/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/libproxy/CMakeLists.txt b/libproxy/CMakeLists.txt
index 65d2754..ecca9dc 100644
--- a/libproxy/CMakeLists.txt
+++ b/libproxy/CMakeLists.txt
@@ -44,9 +44,11 @@ if(UNIX AND NOT APPLE)
find_package(PkgConfig REQUIRED)
function(px_check_modules name)
pkg_check_modules(${name} ${ARGN})
- if (${name}_FOUND)
+ if (${${name}_FOUND})
include_directories(${${name}_INCLUDE_DIRS})
link_directories(${${name}_LIBRARY_DIRS})
+ else()
+ set(${name}_FOUND 0 PARENT_SCOPE)
endif()
endfunction(px_check_modules)
@@ -66,7 +68,7 @@ if(UNIX AND NOT APPLE)
if(X11_FOUND)
px_check_modules(GNOME gconf-2.0)
find_package(KDE4)
- if(${KDE4_FOUND} STREQUAL "TRUE")
+ if("${KDE4_FOUND}" STREQUAL "TRUE")
set(KDE4_FOUND 1)
set(KDE4_LIBRARIES ${KDE4_KDECORE_LIBS})
include_directories(${KDE4_INCLUDE_DIR})
@@ -92,7 +94,7 @@ if(UNIX AND NOT APPLE)
px_module(network_networkmanager ${NM_FOUND} ${NM_LIBRARIES})
px_module_condmod(pacrunner_mozjs JS_DefineFunction ${MOZJS_FOUND} ${MOZJS_LIBRARIES})
px_module_condmod(pacrunner_webkit JSObjectMakeFunctionWithCallback ${WEBKIT_FOUND} ${WEBKIT_LIBRARIES})
- if(GNOME_FOUND)
+ if(${GNOME_FOUND})
add_executable(pxgconf modules/pxgconf.cpp)
target_link_libraries(pxgconf ${GNOME_LIBRARIES})
install(TARGETS pxgconf RUNTIME DESTINATION ${rlibexecdir})