summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorewt <ewt>1998-03-04 16:52:19 +0000
committerewt <ewt>1998-03-04 16:52:19 +0000
commita7328a962db64fb2f9e30ad75d00bb019d5df9ca (patch)
tree98b9f1f65253eafa9764a76ba533579a6945a4f2 /configure.in
parent00adbc84de2ff7f29e916527d78a11a4124bf631 (diff)
downloadlibpopt-r2-4-103.tar.gz
1) check for alloca.h in configure.inr2-4-103
2) use more portable dependency scheme
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a3eea0a..1c1daa0 100755
--- a/configure.in
+++ b/configure.in
@@ -2,8 +2,27 @@ AC_INIT(popt.h)
AC_PROG_CC
AC_GCC_TRADITIONAL
+AC_PROG_RANLIB
+AC_PROG_INSTALL
-AC_CHECK_HEADER(unistd.h)
+dnl
+dnl if CC is gcc, we can rebuild the dependencies (since the depend rule
+dnl requires gcc). If it's not, don't rebuild dependencies -- use what was
+dnl shipped with RPM.
+dnl
+if test X"$GCC" = Xyes ; then
+ TARGET="depend allprogs"
+else
+ TARGET="everything"
+ #
+ # let the Makefile know that we're done with `depend', since we don't
+ # have gcc we're not going to rebuild our dependencies at all.
+ #
+ echo > .depend-done
+fi
+AC_SUBST(TARGET)
+
+AC_CHECK_HEADERS(unistd.h alloca.h)
AC_CHECK_FUNCS(mmap)
AC_CHECK_FUNCS(strerror)