summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@acm.org>2016-06-28 19:18:09 -0700
committerJohn Bowler <jbowler@acm.org>2016-07-01 11:27:43 -0700
commit0ac91cc657ff18f48675183f09fc4a2102fe8dd4 (patch)
tree33881186c0df263af6298c55d622e78d99a54302 /Makefile.am
parentd9779744f9e1e7211933e12701a05c80c93c9de2 (diff)
downloadlibpng-0ac91cc657ff18f48675183f09fc4a2102fe8dd4.tar.gz
pngcp: tool to copy PNG files
This adds pngcp to the build together with a pngcp.dfa configuration test; the test revealed some configuration bugs which are fixed by corrections to the _SUPPORTED macros. pngcp builds on all tested configurations and a number of bugs have been fixed to make this happen relative to the version in libpng 1.7 contrib/examples. pngcp.dfa will have to be different for 1.7 but pngcp.c should work fine (not yet tested). pngcp itself is still missing a usage message; this is a preliminary version, although since it behaves the same way as 'cp' most unoids shouldn't have a problem using it correctly. Signed-off-by: John Bowler <jbowler@acm.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 721295184..39e9bdeed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@ check_PROGRAMS += timepng
endif
# Utilities - installed
-bin_PROGRAMS= pngfix png-fix-itxt
+bin_PROGRAMS= pngcp pngfix png-fix-itxt
# This ensures that pnglibconf.h gets built at the start of 'make all' or
# 'make check', but it does not add dependencies to the individual programs,
@@ -53,6 +53,9 @@ pngfix_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
png_fix_itxt_SOURCES = contrib/tools/png-fix-itxt.c
+pngcp_SOURCES = contrib/tools/pngcp.c
+pngcp_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
+
# Generally these are single line shell scripts to run a test with a particular
# set of parameters:
TESTS =\
@@ -230,6 +233,7 @@ contrib/libtests/timepng.o: pnglibconf.h
contrib/tools/makesRGB.o: pnglibconf.h
contrib/tools/pngfix.o: pnglibconf.h
+contrib/tools/pngcp.o: pnglibconf.h
# We must use -DPNG_NO_USE_READ_MACROS here even when the library may actually
# be built with PNG_USE_READ_MACROS; this prevents the read macros from