summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoachim Nilsson <troglobit@gmail.com>2019-09-28 13:30:55 +0200
committerJoachim Nilsson <troglobit@gmail.com>2019-09-28 13:30:55 +0200
commitdda691d94726f23f8fdac581198d9b0eec2d8db0 (patch)
treef58eb8b247c6d05d2f1d4fc0241b4648efc2d820 /Makefile.am
parent39d3f28a12cdbd817294262025d84a30815f8887 (diff)
parent5e93c69e3b6966bf2ff7af3d32122d23fea01450 (diff)
downloadlibnet-dda691d94726f23f8fdac581198d9b0eec2d8db0.tar.gz
Merge branch 'master' of https://github.com/sgeto/libnet into sgeto-master
Conflicts: .gitignore .travis.yml BUILD-FROM-GIT.txt Makefile.am Makefile.am.common Prepare acinclude.m4 autogen.sh configure.ac doc/html/Makefile.am doc/html/closed.png doc/html/globals_func.html doc/html/tab_s.png doc/libnet.doxygen.conf doc/man/Makefile.am doc/man/man3/Makefile.am doc/man/man3/libnet-functions.h.3 doc/man/man3/libnet-macros.h.3 include/libnet.h include/libnet/Makefile.am libnet/acinclude.m4 libnet/libnet-config.in libnet/m4/acinclude.m4 lua/Makefile lua/msvcbuild.bat sample/Makefile.am scripts/Push src/libnet_link_win32.c win32/Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 52 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 2826478..8a1e4c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,3 @@
-# $Id: Makefile.am,v 1.7 2004/03/01 20:26:11 mike Exp $
#
# Libnet automake information file
# Copyright (c) 1998 - 2004 Mike D. Schiffman <mike@infonexus.com>
@@ -6,16 +5,62 @@
#
# Process this file with automake to produce a Makefile.in script.
-include $(top_srcdir)/Makefile.am.common
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-doxygen-doc \
+ --disable-samples
+
+# Include macros implemented in the directory m4
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+SUBDIRS = include src doc win32
+
+if ENABLE_SAMPLES
+SUBDIRS += sample
+endif
+
+# deleting doc/libnet.tag forces make to rebuild all docs (if enabled)
+CLEANFILES = doc/libnet.tag libnet.pc
+DISTCLEANFILES = fixmanpages
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libnet.pc
-SUBDIRS = include src sample doc win32
-
-EXTRA_DIST = Makefile.am.common msvcbuild.bat
-EXTRA_DIST += README.win32 map-pblock-types
if ENABLE_DOXYGEN
-all: @DX_DOCDIR@/@PACKAGE@.tag
+all: doxygen-doc
@DX_RULES@
+
+all:
+ $(AM_V_GEN)cd $(DX_DOCDIR) && ./fixmanpages && cd -
endif
+
+doc: doxygen-doc
+ $(AM_V_GEN)cd $(DX_DOCDIR) && ./fixmanpages && cd -
+
+EXTRA_DIST = msvcbuild.bat \
+ README.win32 \
+ autogen.sh \
+ map-pblock-types
+
+APIDOCS = $(top_srcdir)/doc/api/*.html \
+ $(top_srcdir)/doc/api/*.css \
+ $(top_srcdir)/doc/api/*.png
+
+APIDOC_DEPS = $(top_srcdir)/doc/libnet.doxygen.conf \
+ $(top_srcdir)/doc/libnet.Pod \
+ $(top_srcdir)/doc/libnet-config.Pod \
+ $(top_srcdir)/doc/libnet_api_header.html_tmpl \
+ $(top_srcdir)/doc/libnet_api_footer.html_tmpl \
+ $(top_srcdir)/doc/libnet_api_stylesheet.css_tmpl
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(docdir)/api
+ $(INSTALL_DATA) `test -f doc/api/index.html || echo $(srcdir)/`doc/api/*.png $(DESTDIR)$(docdir)/api
+ $(INSTALL_DATA) `test -f doc/api/index.html || echo $(srcdir)/`doc/api/*.css $(DESTDIR)$(docdir)/api
+ $(INSTALL_DATA) `test -f doc/api/index.html || echo $(srcdir)/`doc/api/*.html $(DESTDIR)$(docdir)/api
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(docdir)/api
+
+# (GNU make only) Unless we say otherwise, spare us the
+# “Entering/Leaving directory ...” messages
+GNUMAKEFLAGS = $(if $(value VERBOSE),,--no-print-directory)