summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoachim Nilsson <troglobit@gmail.com>2019-10-07 17:26:32 +0200
committerJoachim Nilsson <troglobit@gmail.com>2019-10-07 17:28:05 +0200
commitcb0288e5fb5709cfb566cd2e65b53a290acd3ffd (patch)
tree4aaec5e0b79d403a8bb892287bbd0d2d1149d643 /Makefile.am
parentc1db585e80f7c3222a9c72b519855105b8dd8e7c (diff)
downloadlibnet-cb0288e5fb5709cfb566cd2e65b53a290acd3ffd.tar.gz
Revert "Remove libnet-config, replaced by pkg-config support"
This reverts the removal of libnet-config.in from commit b4063cc. The reason being it is easier to maintain it during a transitional period, for compatibility with existing projects. Signed-off-by: Joachim Nilsson <troglobit@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d9036b..52dac58 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,10 +6,12 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-doxygen-doc --disable-samples
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+bin_SCRIPTS = libnet-config
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libnet.pc
doc_DATA = README.md ChangeLog.md LICENSE
-EXTRA_DIST = README.md ChangeLog.md LICENSE README.win32 autogen.sh
+EXTRA_DIST = README.md ChangeLog.md LICENSE README.win32 autogen.sh \
+ libnet-config.in
SUBDIRS = bin include src win32
if ENABLE_DOXYGEN