summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLinus Walleij <triad@df.lth.se>2011-01-18 15:33:09 +0100
committerLinus Walleij <triad@df.lth.se>2011-01-23 09:02:07 +0100
commit5cf12e7a959341208a74bbc17bd268342328afd2 (patch)
tree08e97034e1610b2cba89d3fd495a83923b25595c /configure.ac
parent68c383ee6c9645270ebeb16c9bd8ce804cc98b33 (diff)
downloadlibmtp-5cf12e7a959341208a74bbc17bd268342328afd2.tar.gz
Patch the udev file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9aef87..5a541e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,13 @@ AM_ICONV
# nothing else makes sense for this.
libexecdir=/lib/udev
+# Optionally set udev rules file name
+UDEV_RULES_FILE=libmtp.rules
+AC_ARG_WITH(udev-rules-file,
+ AC_HELP_STRING([--with-udev-rules-file=NAME],
+ [udev rules file name [default=libmtp.rules]]), [UDEV_RULES_FILE="$withval"], [])
+AC_SUBST(UDEV_RULES_FILE)
+
# Optionally enable and check for doxygen
AC_ARG_ENABLE([doxygen],
AS_HELP_STRING([--enable-doxygen], [Build API documentation using Doxygen]),