summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index a484e253..2c8660bf 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -70,3 +70,10 @@ install-data-hook:
uninstall-local:
rm -f $(DESTDIR)$(bindir)/libinput-list-devices
rm -f $(DESTDIR)$(bindir)/libinput-debug-events
+
+SUFFIXES = .man
+.man.1:
+ $(AM_V_GEN)$(SED) -e 's|\@LIBINPUT_VERSION\@|$(PACKAGE_VERSION)|' < $< > $@
+CLEANFILES = *.1
+EXTRA_DIST += $(dist_man1_MANS:.1=.man)
+