summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-12-06 12:01:47 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-02-24 09:29:09 +1000
commitf925cee8dfa26c24d864f0389e153ce57298209b (patch)
treeb976feaf68c8ffd5519b441fcdbc4e8410cf7a0f /configure.ac
parent3a07b03df5b78fc4a941db5154bef3d9fbf5a0e4 (diff)
downloadlibinput-f925cee8dfa26c24d864f0389e153ce57298209b.tar.gz
Hook up libevdev as backend
libevdev wraps the various peculiarities of the evdev kernel API into a type-safe API. It also buffers the device so checking for specific features at a later time is easier than re-issuing the ioctls. Plus, it gives us almost free support for SYN_DROPPED events (in the following patch). This patch switches all the bit checks over to libevdev and leaves the event processing as-is. Makes it easier to review. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 44729a90..68e1d358 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,7 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(MTDEV, [mtdev >= 1.1.0])
PKG_CHECK_MODULES(LIBUDEV, [libudev])
+PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
@@ -64,20 +65,16 @@ AC_ARG_ENABLE(tests,
[build_tests="$enableval"],
[build_tests="auto"])
-PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4], [HAVE_LIBEVDEV="yes"], [HAVE_LIBEVDEV="no"])
PKG_CHECK_MODULES(CHECK, [check >= 0.9.9], [HAVE_CHECK="yes"], [HAVE_CHECK="no"])
if test "x$build_tests" = "xauto"; then
- if test "x$HAVE_CHECK" = "xyes" -a "x$HAVE_LIBEVDEV" = "xyes"; then
+ if test "x$HAVE_CHECK" = "xyes"; then
build_tests="yes"
fi
fi
if test "x$build_tests" = "xyes" -a "x$HAVE_CHECK" = "xno"; then
AC_MSG_ERROR([Cannot build tests, check is missing])
fi
-if test "x$build_tests" = "xyes" -a "x$HAVE_LIBEVDEV" = "xno"; then
- AC_MSG_ERROR([Cannot build tests, libevdev is missing])
-fi
AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])