summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-03-27 11:04:24 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-04-10 11:11:56 +1000
commitc0730036915b6965846e043613939433dd5f7c1e (patch)
treed062178c975dd9456ffea50d98af0f4f5a3f3167 /configure.ac
parentfe4a40cdec39ae77d9c6ced4796711b51dfe886c (diff)
downloadlibinput-c0730036915b6965846e043613939433dd5f7c1e.tar.gz
test: automatically run the tests against valgrind for leaks
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index faae1481..4cb08685 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,10 +73,15 @@ if test "x$build_tests" = "xauto"; then
build_tests="yes"
fi
fi
-if test "x$build_tests" = "xyes" -a "x$HAVE_CHECK" = "xno"; then
- AC_MSG_ERROR([Cannot build tests, check is missing])
+if test "x$build_tests" = "xyes"; then
+ if test "x$HAVE_CHECK" = "xno"; then
+ AC_MSG_ERROR([Cannot build tests, check is missing])
+ fi
+
+ AC_PATH_PROG(VALGRIND, [valgrind])
fi
+AM_CONDITIONAL(HAVE_VALGRIND, [test "x$VALGRIND" != "x"])
AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])
AC_CONFIG_FILES([Makefile