summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-06-06 09:38:35 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-06-10 20:54:53 +1000
commit63927631a46508d3d5157303522511cdd891869b (patch)
treece6ce111c689cc248eca5cd2e52bd949e68895df /configure.ac
parente64a0147cdcf17797c78b46abe6dfda3503f03b6 (diff)
downloadlibinput-63927631a46508d3d5157303522511cdd891869b.tar.gz
test: silence compiler warning for C++ build test
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++ [enabled by default] Since gcc also complains about adding -Wno-strict-prototypes we have to handle the two separately. A side-effect here: now that we promote the GCC_CFLAGS to AM_CFLAGS, litest.la is built with the correct CFLAGS too. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Hans de Goede <hdegoede@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d8e3358a..13cf3a81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,9 +59,11 @@ PKG_CHECK_MODULES(LIBUDEV, [libudev])
PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
if test "x$GCC" = "xyes"; then
- GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
+ GCC_CXXFLAGS="-Wall -Wextra -Wno-unused-parameter -g -fvisibility=hidden"
+ GCC_CFLAGS="$GCC_CXXFLAGS -Wmissing-prototypes -Wstrict-prototypes"
fi
AC_SUBST(GCC_CFLAGS)
+AC_SUBST(GCC_CXXFLAGS)
AC_PATH_PROG(DOXYGEN, [doxygen])
if test "x$DOXYGEN" = "x"; then