summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-01-28 11:25:40 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-01-31 14:57:19 +1000
commit3444b29ceb47694fc3a1d0e3c3588376cd79354c (patch)
treecb91769b2b7a1e808991ef23fcc3cac7500b811a /configure.ac
parent20416ae4b70ba439290dd85d5c43f5c18b224182 (diff)
downloadlibinput-3444b29ceb47694fc3a1d0e3c3588376cd79354c.tar.gz
tools: add a tool for basic event debugging
Simply prints the various events to make it easier to check what's coming out of libinput. Works for --udev (the default) or for --device /dev/input/event0. Example output: event7 DEVICE_ADDED seat0 default event8 DEVICE_ADDED seat0 default event4 POINTER_BUTTON +1.35s 272 pressed event5 POINTER_MOTION +2.31s -3.00/ 2.00 Time is displayed relative to the starting time. Note: statically linked for easier debugging, but we don't distribute it (yet) anyway. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7281bb4e..44729a90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,5 +87,6 @@ AC_CONFIG_FILES([Makefile
src/Makefile
src/libinput.pc
src/libinput-version.h
- test/Makefile])
+ test/Makefile
+ tools/Makefile])
AC_OUTPUT