summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-12-06 09:58:00 +1000
committerJonas Ã…dahl <jadahl@gmail.com>2013-12-07 14:06:46 +0100
commit2d2df7842c618871328f0bfa71b66f9378831250 (patch)
tree5763e7648eeee09eb5142c139381afcb0fd38165 /configure.ac
parent075119dd5a5b9e780e8c779c26b38adc690381a7 (diff)
downloadlibinput-2d2df7842c618871328f0bfa71b66f9378831250.tar.gz
doc: hook up doxygen to generate the public API documentation
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 08472cf0..f15a7ba9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,7 +49,18 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(GCC_CFLAGS)
+AC_PATH_PROG(DOXYGEN, [doxygen])
+if test "x$DOXYGEN" = "x"; then
+ AC_MSG_WARN([doxygen not found - required for documentation])
+ have_doxygen="no"
+else
+ have_doxygen="yes"
+fi
+AM_CONDITIONAL([HAVE_DOXYGEN], [test "x$have_doxygen" = "xyes"])
+
AC_CONFIG_FILES([Makefile
+ doc/Makefile
+ doc/libinput.doxygen
src/Makefile
src/libinput.pc
src/libinput-version.h])