summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-12-06 14:17:35 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-01-10 14:17:06 +1000
commit00496411169f7f8cb85ec73edc6f4093035fa659 (patch)
tree0f8761c81d95cf43e749cfe95dc600dbe6eb21b3 /configure.ac
parent7d51d769a653f2a9910cbc0eedb52cbed573049c (diff)
downloadlibinput-00496411169f7f8cb85ec73edc6f4093035fa659.tar.gz
Add the framework for a test suite
Just the scaffolding, no actual tests just yet Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d027708..0d34623a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,10 +59,18 @@ else
fi
AM_CONDITIONAL([HAVE_DOXYGEN], [test "x$have_doxygen" = "xyes"])
+AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--enable-tests], [Build the tests (default=yes)]),
+ [build_tests="$enableval"],
+ [build_tests="yes"])
+
+AM_CONDITIONAL(BUILD_TESTS, [test "x$build_tests" = "xyes"])
+
AC_CONFIG_FILES([Makefile
doc/Makefile
doc/libinput.doxygen
src/Makefile
src/libinput.pc
- src/libinput-version.h])
+ src/libinput-version.h
+ test/Makefile])
AC_OUTPUT