summaryrefslogtreecommitdiff
path: root/src/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2015-02-16 18:32:25 -0500
committerAllen Winter <allen.winter@kdab.com>2015-02-16 18:32:25 -0500
commitbb6f80487d286e0469329426a9dc3c128459fc78 (patch)
tree76ed869e481fbd41d70e6a915036fdd5b25f93cd /src/test/CMakeLists.txt
parent5b831d7f7463a4670db7c3ba11e9111345fc01f7 (diff)
downloadlibical-git-bb6f80487d286e0469329426a9dc3c128459fc78.tar.gz
reduce warnings when building test regression test with static libs
and with C++ bindings. getting better.
Diffstat (limited to 'src/test/CMakeLists.txt')
-rw-r--r--src/test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
index 3146b876..bf6a00e8 100644
--- a/src/test/CMakeLists.txt
+++ b/src/test/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(NOT SHARED_ONLY)
+ add_definitions(-DLIBICAL_ICAL_STATIC_DEFINE)
+endif()
+
include_directories(
${CMAKE_BINARY_DIR}
${CMAKE_SOURCE_DIR}/src