summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChoe Hwanjin <choe.hwanjin@gmail.com>2007-01-06 15:14:45 +0900
committerChoe Hwanjin <choe.hwanjin@gmail.com>2007-01-06 15:14:45 +0900
commit1cd9521c3e55af0d0636ad0e25134920e27405b6 (patch)
tree53080054efc79a84d0212cd80bceedbc0766526f /configure.ac
parent53dcef4aba4eb10dd1b057142074079ed0191a5f (diff)
downloadlibhangul-1cd9521c3e55af0d0636ad0e25134920e27405b6.tar.gz
hangulconfig.h:libhangul-0.0.4
* hangulconfig.h를 자동 생성하는 룰 제거 * stdboo.h를 직접 include hangul.h: * _HANGUL_H_ 대신 libhangul_hangul_h 로 헤더 중복 include 체크 version: * 0.0.4 준비 작업 git-svn-id: http://kldp.net/svn/hangul/libhangul/trunk@109 8f00fcd2-89fc-0310-932e-b01be5b65e01
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 1 insertions, 40 deletions
diff --git a/configure.ac b/configure.ac
index a476897..fdc7680 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
-AC_INIT(libhangul, 0.0.3, http://kldp.net/projects/hangul/)
+AC_INIT(libhangul, 0.0.4, http://kldp.net/projects/hangul/)
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([hangul/hangul.h])
AC_CONFIG_HEADER([config.h])
@@ -30,45 +30,6 @@ AC_HEADER_STDBOOL
AC_C_CONST
AC_C_INLINE
-
-# Generate hangulconf.h file
-AC_CONFIG_COMMANDS([hangulconfig.h],
-[
- outfile=hangulconfig.h
- cat > $outfile << _HANGULCONFEOF
-/* hangulconfig.h
- * This is generated file. Do not directly modify this.
- */
-
-_HANGULCONFEOF
-
-if test "$stdbool_h" = "yes" ; then
- echo "#include <stdbool.h>" >> $outfile
-else
- if test "$bool_type" != "yes" ; then
- cat >> $outfile << _HANGULCONFEOF
-# ifdef __cplusplus
- typedef bool _Bool;
-# else
- typedef unsigned char _Bool;
-#endif
-_HANGULCONFEOF
- fi
-
- cat >> $outfile << _HANGULCONFEOF
-#define bool _Bool
-#define false 0
-#define true 1
-#define __bool_true_false_are_defined 1
-_HANGULCONFEOF
-fi
-], [
-
-stdbool_h="$ac_cv_header_stdbool_h"
-bool_type="$ac_cv_type__Bool"
-
-])
-
# Checks for library functions.
AC_CONFIG_FILES([
Makefile