summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2022-05-18 13:26:55 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2022-05-19 17:11:24 +0200
commit6f5bd93820fa835c744aede2a5f4635693ac424e (patch)
tree83d4d3a487031dd964882b2f7ebb2fe1055c66e7 /tests/Makefile.am
parentab3af6f5003221289bc39693a5e482396ad591dd (diff)
downloadlibgphoto2-6f5bd93820fa835c744aede2a5f4635693ac424e.tar.gz
Add test-init-localedir test program
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5eef508a8..d87bc3d61 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -99,6 +99,16 @@ test_camera_list_LDADD = \
$(INTLLIBS)
+TESTS += test-init-localedir
+check_PROGRAMS += test-init-localedir
+test_init_localedir_LDADD =
+test_init_localedir_LDADD += $(top_builddir)/libgphoto2/libgphoto2.la
+test_init_localedir_LDADD += $(top_builddir)/libgphoto2_port/libgphoto2_port/libgphoto2_port.la
+test_init_localedir_LDADD += $(LIBLTDL)
+test_init_localedir_LDADD += $(LIBEXIF_LIBS)
+test_init_localedir_LDADD += $(INTLLIBS)
+
+
########################################################################
# Test pedantic compilation for multiple language standard
########################################################################