summaryrefslogtreecommitdiff
path: root/libgphoto2_port/configure.ac
diff options
context:
space:
mode:
authorMarcus Meissner <marcus@jet.franken.de>2017-07-22 12:04:55 +0200
committerMarcus Meissner <marcus@jet.franken.de>2017-07-22 12:05:36 +0200
commit26cf4a929f726d3f26b2ee12056ce01b7498d4c0 (patch)
tree85f65b07af61a0c0676bf9f4d0a120f8fe403f5f /libgphoto2_port/configure.ac
parentc91aef1c5e2576c128321a5fc874677017850f1a (diff)
downloadlibgphoto2-26cf4a929f726d3f26b2ee12056ce01b7498d4c0.tar.gz
make vusb not-default ... some users are confused why there is a virtual PTP camera
Diffstat (limited to 'libgphoto2_port/configure.ac')
-rw-r--r--libgphoto2_port/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/libgphoto2_port/configure.ac b/libgphoto2_port/configure.ac
index e75a58501..652a6dd40 100644
--- a/libgphoto2_port/configure.ac
+++ b/libgphoto2_port/configure.ac
@@ -429,6 +429,19 @@ if test "x$enable_disk" = "xyes"; then
IOLIB_LIST="$IOLIB_LIST disk"
fi
+AC_ARG_ENABLE([vusb],
+ AS_HELP_STRING([--enable-vusb], [enable the 'vusb' virtual USB port driver]),
+ ,[
+ enable_vusb=no
+ GP_CONFIG_MSG([virtual USB support],[disabled, no virtual PTP test camera])
+ ]
+)
+
+dnl disk port also works everywhere, but it's not really necessary
+if test "x$enable_vusb" = "xyes"; then
+ IOLIB_LIST="$IOLIB_LIST vusb"
+fi
+
AC_ARG_ENABLE([ptpip],
AS_HELP_STRING([--disable-ptpip], [disable the 'ptpip' port driver for TCP/IP connected PTP cameras]),
,enable_ptpip=yes)
@@ -437,8 +450,6 @@ if test "x$enable_ptpip" = "xyes"; then
IOLIB_LIST="$IOLIB_LIST ptpip"
fi
-IOLIB_LIST="$IOLIB_LIST vusb"
-
# ----------------------------------------------------------------------
# Define IOLIB stuff
# ----------------------------------------------------------------------