summaryrefslogtreecommitdiff
path: root/libgphoto2/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-19 00:06:23 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-25 00:20:21 +0200
commit0b2b6207c24bfab3878185d1f907fd0d960931da (patch)
treea9e6773370c5a9f2b7f358031ec15ac35dd0effe /libgphoto2/Makefile.am
parentb6e9e97fe8a12fde1aa3486be563c3362005de8e (diff)
downloadlibgphoto2-0b2b6207c24bfab3878185d1f907fd0d960931da.tar.gz
Factor out i18n stuff into separate i18n.h files
Factor out the i18n definitions into i18n.h include files: One include file each for libgphoto2 and for libgphoto2_port. This removes the complete #ifdef ENABLE_NLS # include <libintl.h> # undef _ # define _(String) dgettext (GETTEXT_PACKAGE, String) # ifdef gettext_noop # define N_(String) gettext_noop (String) # else # define N_(String) (String) # endif #else # define _(String) (String) # define N_(String) (String) #endif block (which in some occasions defines even more macros) and replaces it with a single line #include "libgphoto2/i18n.h" for camlibs and libgphoto2 itself and with #include "libgphoto2_port/i18n.h" for iolibs and libgphoto2_port itself. This gives us two central locations to change the defintions.
Diffstat (limited to 'libgphoto2/Makefile.am')
-rw-r--r--libgphoto2/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libgphoto2/Makefile.am b/libgphoto2/Makefile.am
index dde166998..18809dcfb 100644
--- a/libgphoto2/Makefile.am
+++ b/libgphoto2/Makefile.am
@@ -55,3 +55,5 @@ libgphoto2_la_DEPENDENCIES = \
$(srcdir)/libgphoto2.sym
EXTRA_DIST = gphoto2-library.c libgphoto2.sym
+
+EXTRA_DIST += i18n.h