summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-27 00:54:44 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-11-03 21:18:55 +0100
commiteef3638d227625e7d4c75bf536b3d5abb823b423 (patch)
tree7d53a98b6df18bbdc021073c01e1c632ef94883a /configure.ac
parentd7823edd44b5b6b7ea5ddb6d222dac07ff0ae217 (diff)
downloadlibgphoto2-eef3638d227625e7d4c75bf536b3d5abb823b423.tar.gz
tests: add pedantic compile tests for -std={c2x,c++20}
Add a pedantic C compile test for c2x in addition to the existing ones for c90, c99, and c11. Add a pedantic C++ compile test for c++20 in addition to the existing ones for c++98, c++11, c++14, and c++17.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05a8320f5..c7b73f050 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,11 +106,13 @@ dnl --------------------------------------------------------------------
GP_PEDANTIC_COMPILER_FLAGS([C90], [C], [-std=c90])
GP_PEDANTIC_COMPILER_FLAGS([C99], [C], [-std=c99])
GP_PEDANTIC_COMPILER_FLAGS([C11], [C], [-std=c11])
+GP_PEDANTIC_COMPILER_FLAGS([C2X], [C], [-std=c2x])
dnl
GP_PEDANTIC_COMPILER_FLAGS([CXX98], [C++], [-std=c++98])
GP_PEDANTIC_COMPILER_FLAGS([CXX11], [C++], [-std=c++11])
GP_PEDANTIC_COMPILER_FLAGS([CXX14], [C++], [-std=c++14])
GP_PEDANTIC_COMPILER_FLAGS([CXX17], [C++], [-std=c++17])
+GP_PEDANTIC_COMPILER_FLAGS([CXX20], [C++], [-std=c++20])
GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS],[-Wall])
GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS],[-Wextra])