summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2022-02-14 23:59:52 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2022-03-30 15:11:14 +0200
commitbe104b3e906c5f6dfc464fb462028fb3597295d1 (patch)
treeba4a36dae881558e4b2da12004b5a8a1f15512e9 /configure.ac
parentdac8272132b83cf3b1e94ad5e8ce2e1981436ffc (diff)
downloadlibgphoto2-be104b3e906c5f6dfc464fb462028fb3597295d1.tar.gz
For clang, use -Wmost instead of -Weverything
I have found good arguments from clang developers for not using -Weverything after all. Instead, -Wmost is the preferred option to enable the most warnings reasonable. Apparently, -Weverything can a set of warnings where one warning contradicts the other and is really only useful people developing clang itself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bfeff449a..9ff09a354 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,7 +177,7 @@ GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Werror=unknown-warning-option])
GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Wall])
GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Wextra])
-GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Weverything])
+GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Wmost])
dnl We used to have these two defined for GCC instead of the whole -Wextra
dnl GP_CONDITIONAL_COMPILE_FLAGS([CFLAGS], [-Wmissing-declarations])