summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2001-11-29 01:39:49 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2001-11-29 01:39:49 +0000
commitefe3cc5cfc6e34bf024e0d17dae6467b8282ffcb (patch)
treec6235fcb97b342b1953cd280a8f5aefd88396a3a /Makefile.am
parente1c37d79d0719c2bedaaaea6c79c8724dc3276ac (diff)
downloadlibgphoto2-efe3cc5cfc6e34bf024e0d17dae6467b8282ffcb.tar.gz
2001-11-29 Hans Ulrich Niedermann <hun@n-dimensional.de>
* Makefile.am: enable RPM and CVS rules only when useful * configure.in: init RPM packaging * libgphoto2_port/m4/packaging.m4: added packaging macro git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@3274 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f10b89517..b6ce5cb0d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,15 +50,22 @@ dist-bzip2:
-chmod -R a+r $(distdir)
-$(TAR) chojf $(distdir).tar.bz2 $(distdir)
+if ENABLE_RPM
+
# create RPM packages
.PHONY: rpm
rpm: Makefile
$(MAKE) dist
$(MAKE) -C packaging/rpm rpm
+endif
+
+if MAINTAINER_MODE
+
# add CVS tags - used only by the project maintainer to tag the files of a
# released version
.PHONY: cvs-tags
cvs-tags: Makefile
@echo cvs tag "@PACKAGE@-$$(echo '@VERSION@' | sed 's/\./_/g')"
+endif