summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-11-11 22:54:14 -0500
committerEdward Thomson <ethomson@edwardthomson.com>2021-11-14 07:25:41 -0500
commitc7f6ecb3911b5bc8052428a3605802403c673730 (patch)
tree2c2e64d0a178be7c3db749b55aac4fb1f16f779a /CMakeLists.txt
parent395b3dc403621f1ab3c400780b057cae91c6f6c1 (diff)
downloadlibgit2-c7f6ecb3911b5bc8052428a3605802403c673730.tar.gz
cmake: use a string not a boolean for LIBGIT2_FILENAME
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae0a5d685..664abc0d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,7 +40,7 @@ option(DEBUG_STRICT_OPEN "Enable path validation in open"
# Output options
option(SONAME "Set the (SO)VERSION of the target" ON)
-option(LIBGIT2_FILENAME "Name of the produced binary" OFF)
+ set(LIBGIT2_FILENAME "git2" CACHE STRING "Name of the produced binary")
option(DEPRECATE_HARD "Do not include deprecated functions in the library" OFF)
# Compilation options