summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-08-25 14:11:03 -0400
committerGitHub <noreply@github.com>2021-08-25 14:11:03 -0400
commitc7a195a1c4da41317916141fa0cfd0aabfdecfff (patch)
treeef89d7f19a8df8364f65e22c5fe001d0a5b5780b /CMakeLists.txt
parentefc4e7e56a7b8a406e37ef7b6444996b9e377cc7 (diff)
parent4bbe5e6ea6f2084c4153fb6205115bd43db0a300 (diff)
downloadlibgit2-c7a195a1c4da41317916141fa0cfd0aabfdecfff.tar.gz
Merge pull request #6006 from boretrk/c11-warnings
GCC C11 warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9f544174..fd046eb5c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -235,6 +235,7 @@ ELSE ()
enable_warnings(unused-function)
enable_warnings(int-conversion)
enable_warnings(c11-extensions)
+ enable_warnings(c99-c11-compat)
# MinGW uses gcc, which expects POSIX formatting for printf, but
# uses the Windows C library, which uses its own format specifiers.