summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2023-04-13 23:08:15 +0100
committerGitHub <noreply@github.com>2023-04-13 23:08:15 +0100
commitabb0b313172d1b4477fe0c6e88102ce4bb8db90c (patch)
tree3a10be144189e635044782d76888e40d1d862afa /CMakeLists.txt
parent562feb99c1a27bb5e31fdf8420e076e2f188bf56 (diff)
parent462dbe21d0edc3817d53900702e68d666c303600 (diff)
downloadlibgit2-abb0b313172d1b4477fe0c6e88102ce4bb8db90c.tar.gz
Merge pull request #6482 from libgit2/ethomson/xdiff
xdiff: move xdiff to 'deps'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b505b181c..30527b928 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,7 @@ option(USE_SHA1 "Enable SHA1. Can be set to CollisionDetection(ON
option(USE_SHA256 "Enable SHA256. Can be set to HTTPS/Builtin" ON)
option(USE_GSSAPI "Link with libgssapi for SPNEGO auth" OFF)
set(USE_HTTP_PARSER "" CACHE STRING "Specifies the HTTP Parser implementation; either system or builtin.")
+# set(USE_XDIFF "" CACHE STRING "Specifies the xdiff implementation; either system or builtin.")
set(REGEX_BACKEND "" CACHE STRING "Regular expression implementation. One of regcomp_l, pcre2, pcre, regcomp, or builtin.")
option(USE_BUNDLED_ZLIB "Use the bundled version of zlib. Can be set to one of Bundled(ON)/Chromium. The Chromium option requires a x86_64 processor with SSE4.2 and CLMUL" OFF)